Service Desk portal not available

Incident Report for OpenAthens

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 02:35 BST

Update

We are continuing to work on a fix for this issue.
Posted Sep 15, 2026 - 02:20 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 15, 2026 - 02:19 BST

Investigating

We are currently investigating this issue.
Posted Sep 15, 2026 - 02:05 BST
This incident affected: Service Desk portal.