Service Outage - Service Desk portal - P3

Incident Report for OpenAthens

Resolved

The Service Desk portal is now working as expected. The new portal will have a slightly new look. If you have any questions on this new experience please let us know.
Posted Dec 01, 2025 - 12:39 GMT

Update

The Service Desk portal is working as expected and you are now able to raise tickets as you were before.
Posted Dec 01, 2025 - 12:01 GMT

Identified

The maintenance for our Service Desk portal is ongoing past the original planned downtime.

We appreciate that may cause some disruption and we are working towards a resolution as quick as possible. Thank you for your patience while we carry out improvements to our service.

If you require support, please email help@openathens.net or phone +44 (0) 300 121 0043
Posted Dec 01, 2025 - 09:09 GMT
This incident affected: Service Desk portal.