Account Administration website - Partial Outage
Incident Report for OpenAthens
Resolved
An issue was found that caused local account user activity not to be returned in certain cases, this has now been fixed.
Posted about 2 months ago. Apr 29, 2019 - 14:27 BST
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Apr 26, 2019 - 15:32 BST
Investigating
We are currently experiencing a partial outage with the following service(s):
Account Administration website

Local account activity is currently unavailable and we will update you in due course.
Posted about 2 months ago. Apr 26, 2019 - 15:29 BST
This incident affected: Administration Services (Account Administration website).