Degradation Of Service - SP Dashboard

Incident Report for OpenAthens

Resolved

We have released a fix and enabled the save changes button for connections in the service provider dashboard.
Posted May 09, 2025 - 11:18 BST

Update

We have now disabled the save changes button for connections in the service provider. If you require assistance making any changes please contact the OpenAthens service desk. https://www.openathens.net/support/
Posted May 02, 2025 - 11:53 BST

Investigating

We’re looking into an issue that’s affecting the following service.

SP Dashboard

Some connection rulesets are showing as disabled where they were enabled before. This is an issue in the user interface and the connections and rulesets are still working despite showing as disabled. Please be aware that if you press the save changes button while it's in the incorrect state, it will still save and therefore your connections may break for customers. In the mean time, we are disabling the save changes button. If you notice any issues with your connections then please contact the OpenAthens service desk https://www.openathens.net/support/
Posted May 02, 2025 - 10:41 BST
This incident affected: SP Dashboard.