OpenAthens Archive Statistics - Major Outage
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted Dec 17, 2018 - 14:04 GMT
Investigating
We are currently experiencing a major outage with the following service(s):
OpenAthens Archive Statistics

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted Dec 17, 2018 - 13:36 GMT