Update on OpenAthens Support Portal migration
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 10:51 GMT
Investigating
Please note that we will not move to our new support portal on 7 February 2024, as previously advised.

We need more time to ensure that our customers get a great experience, and we will communicate a revised date as soon as possible.

Currently, no action is required, and we thank customers for their patience.
Posted Feb 05, 2024 - 09:53 GMT
This incident affected: Service Desk portal.