Service Desk web interface - Major Outage
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted 8 days ago. Jun 08, 2019 - 07:14 BST
Investigating
We are currently experiencing a major outage with the following service(s):
Service Desk web interface

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted 8 days ago. Jun 08, 2019 - 06:31 BST
This incident affected: OpenAthens Support (Service Desk web interface).