SP Dashboard - Degraded Performance
Incident Report for OpenAthens
Resolved
We have resolved the underlying issues that were causing service instabilities.
Posted Mar 25, 2020 - 11:44 GMT
Monitoring
A temporary fix has been implemented and we are monitoring the results.
Posted Mar 21, 2020 - 15:14 GMT
Investigating
We are currently experiencing degraded performance with the following service:
SP Dashboard

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted Mar 21, 2020 - 14:53 GMT