OpenAthens Status
Incident Report for OpenAthens
Resolved
After monitoring our service, we are now confident that we are unaffected by the global IT outage.

If you are having any issues then please contact our service desk: https://www.openathens.net/support
Posted Jul 19, 2024 - 17:08 BST
Monitoring
Following the recent news affecting many major IT systems thought to be caused by the Crowdstrike service, please be aware that so far the main OpenAthens service is not affected. Other services may be affected. We are continuing to monitor our service and will provide updates if needed.
Please contact our service desk if you are experiencing any issues.
Posted Jul 19, 2024 - 09:39 BST
This incident affected: Service Desk portal.