Service Desk web interface - Service Outage
Incident Report for OpenAthens
Resolved
The issue has now been resolved, we are still investigating the root cause.
Posted 3 months ago. May 29, 2019 - 08:59 BST
Investigating
We are currently experiencing a major outage with the following service:
Service Desk web interface

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted 3 months ago. May 29, 2019 - 08:51 BST
This incident affected: OpenAthens Support (Service Desk web interface).