Service Desk web interface - Major Outage
Incident Report for OpenAthens
Resolved
Service has been restored, further investigation is required to determine the root cause.
Posted 27 days ago. May 20, 2019 - 05:06 BST
Investigating
We are currently experiencing a major outage with the following service(s):
Service Desk web interface

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted 27 days ago. May 20, 2019 - 04:48 BST
This incident affected: OpenAthens Support (Service Desk web interface).