OpenAthens service desk - opening hours on Thursday 25 June
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 10:08 BST
Monitoring
Please note a change to the opening hours of the OpenAthens service desk for Thursday 25 June. Due to staff training, our opening hours will be 09:00-17:30 GMT on this day only.

Our usual opening hours of 07:00-22:00 GMT will resume from Friday 26 June.
Posted Jun 23, 2020 - 10:47 BST
This incident affected: Service Desk portal.