Service Desk web interface - Major Outage
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted 3 days ago. Jun 13, 2019 - 09:42 BST
Identified
We are currently experiencing a major outage with the following service(s):
Service Desk web interface

Our maintenance on this service is overrunning and we aim to restore the service as soon as possible.
Posted 3 days ago. Jun 13, 2019 - 09:00 BST
This incident affected: OpenAthens Support (Service Desk web interface).