OpenAthens Emergency Maintenance - Service Desk Portal

Incident Report for OpenAthens

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 10:19 GMT

Identified

Apologies for the short notice but we need to perform essential maintenance work on the following service:

Service Desk Portal

There will be a brief outage during a service restart
Posted Nov 24, 2025 - 09:43 GMT
This incident affected: Service Desk portal.