Degradation Of Service - P4
Incident Report for OpenAthens
Resolved
This issue has been resolved.

If you are still having issues then please contact our service desk: https://www.openathens.net/support
Posted Oct 25, 2023 - 11:33 BST
Investigating
We’re currently investigating an issue affecting our discovery tool, Wayfinder. A small amount of customers may see duplicate entries when searching for their institution. This is not affecting the ability of those institutions to login if the correct entry is selected. If a user selects the incorrect entry they will be unable to login and may see a timeout message in their browser, but are able to then go back and select the correct entry.
An update will be provided as soon as possible.
Posted Oct 24, 2023 - 17:47 BST
This incident affected: Wayfinder.