OpenAthens service desk - opening hours on Thursday 18 February
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 16:39 GMT
Monitoring
Please note a change to the opening hours for the OpenAthens service desk on Thursday 18 February. Due to an internal team activity, our opening hours will be 09:00-17:30 GMT on this day only.

Our usual opening hours of 07:00-22:00 GMT will resume from Friday 19 February.
Posted Feb 16, 2021 - 11:40 GMT
This incident affected: Service Desk portal.