Service Outage - P3
Incident Report for OpenAthens
Resolved
OpenAthens is back to normal.
Posted Oct 13, 2020 - 07:05 BST
Investigating
We’re looking into an issue that's preventing OpenAthens users from accessing the following service(s).

Service Desk portal

Our team is working to understand what has caused the issue and we will update you within the next hour.
Posted Oct 13, 2020 - 07:01 BST
This incident affected: Service Desk portal.