Service Desk web interface - Major Outage
Incident Report for OpenAthens
Resolved
Service has been restored, further investigation is required to determine the root cause.
Posted about 1 month ago. May 10, 2019 - 06:48 BST
Investigating
We are currently experiencing a major outage with the following service:
Service Desk web interface

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted about 1 month ago. May 10, 2019 - 06:31 BST
This incident affected: OpenAthens Support (Service Desk web interface).