Incident with https://archive.openathens.net/
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted May 16, 2018 - 10:07 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2018 - 16:53 BST
Update
We are continuing to investigate this issue.
Posted May 15, 2018 - 15:11 BST
Investigating
We are currently investigating an issue with https://archive.openathens.net/.
Posted May 15, 2018 - 15:03 BST
This incident affected: Account Administration website.