Support Portal - Partial Outage
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 07, 2019 - 13:20 GMT
Investigating
We are currently experiencing a partial outage with the following service(s):
Support Portal

Further investigation is underway, and we will aim to provide more information in the next hour.
Posted 2 months ago. Mar 07, 2019 - 12:39 GMT
This incident affected: OpenAthens Support (Service Desk, Service Desk web interface).