Service Desk Telephone Support - Outage
Incident Report for OpenAthens
Resolved
We are pleased to advise customers that the issue affecting the OpenAthens service desk telephones is now resolved, and we would like to apologise for any inconvenience caused.
Posted Nov 30, 2020 - 09:48 GMT
Investigating
We are currently experiencing an outage with the OpenAthens Service Desk Telephones.

Further investigation is underway and we will provide further updates as soon as possible. In the meantime tickets can be raised via the Support Portal: https://support.openathens.net/login.jsp.
Posted Nov 27, 2020 - 16:58 GMT