OpenAthens service desk - opening hours on Tuesday 12 October
Incident Report for OpenAthens
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 09:38 BST
Monitoring
Please note a change to the OpenAthens service desk opening hours on Tuesday 12 October. Due to a company away day, our opening hours will be 09:00-17:30 BST on this day only.

Our usual opening hours of 07:00-22:00 BST will resume from Wednesday 13 October.
Posted Oct 08, 2021 - 15:11 BST
This incident affected: Service Desk portal.