OpenAthens Service Incident
Incident Report for OpenAthens
Resolved
This incident was caused by an issue on our Cloud providers network severely impacting many high profile internet services including OpenAthens. The incident was resolved Tuesday 17th July 21:59 UK time.
Posted Jul 18, 2018 - 08:44 BST
Monitoring
We are currently investigating an issue with one or more of our services.

Select incident title for further details.
Posted Jul 17, 2018 - 20:15 BST
This incident affected: Authentication Point, Managed Proxy service, Wayfinder, and Account Administration website.